在npm install命令中出错

npm install命令结束时出现错误。

 angular#1.2.1 bower_components\angular npm ERR! peerinvalid The package karma-requirejs does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer karma@0.10.10 wants karma-requirejs@~0.2.0 npm ERR! System Windows_NT 6.1.7600 npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" npm ERR! cwd F:\AngularExamples\KarmaTest546\AngularJS-Testing-Article npm ERR! node -v v0.10.28 npm ERR! npm -v 1.4.9 npm ERR! code EPEERINVALID npm ERR! npm ERR! Additional logging details can be found in: npm ERR! F:\AngularExamples\KarmaTest546\AngularJS-Testing-Article\npm-debug .log npm ERR! not ok code 0 

虽然我已经允许克隆下git而不是git使用git config --global url."https://".insteadOf git://

package.json: –

 { "name": "yom-angularjs-testing-article", "version": "0.0.0", "repository": { "type": "git", "url": "https://github.com/matsko/YOM-AngularJS-Testing-Article" }, "scripts": { "postinstall": "./node_modules/.bin/bower install" }, "homepage": "https://github.com/yearofmoo/YOM-AngularJS-Testing-Article", "devDependencies": { "grunt": "~0.4.1", "grunt-css": "~0.5.4", "grunt-contrib-connect": "~0.1.2", "grunt-contrib-uglify": "~0.2.1", "grunt-contrib-concat": "~0.3.0", "grunt-contrib-watch": "~0.4.4", "grunt-shell": "~0.2.2", "grunt-contrib-copy": "~0.4.1", "karma-mocha": "latest", "karma-chrome-launcher": "~0.1.0", "karma-safari-launcher": "latest", "karma-firefox-launcher": "~0.1.0", "karma-ng-scenario": "latest", "chai": "1.4.0", "karma-script-launcher": "~0.1.0", "karma-html2js-preprocessor": "~0.1.0", "karma-jasmine": "~0.1.3", "karma-requirejs": "~0.1.0", "karma-coffee-preprocessor": "~0.1.0", "karma-phantomjs-launcher": "~0.1.0", "karma": "~0.10.2", "grunt-karma": "~0.6.2", "grunt-open": "~0.2.2", "ng-midway-tester": "2.0.5", "bower": "~1.2.7" } } 

有人可以为此提出一个解决scheme吗?

       

网上收集的解决方案 "在npm install命令中出错"

那么, karma 0.10需要karma-requirejs 0.2 ,你可以看到:

 npm ERR! peerinvalid The package karma-requirejs does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer karma@0.10.10 wants karma-requirejs@~0.2.0 

然而在你的package.json中你指定了karma-requirejs 0.1

调整,以满足要求,它应该工作

升级业力版本..就是这样.. "karma": "~0.12.0"