npm install缺less模块

在我可以在我的项目中运行npm install之前,我需要运行npm install 。 这工作除了我的电脑,因为我得到以下错误:

 Error: Cannot find module 'socket.io' at Function.Module._resolveFilename (module.js:338:15) at Function.Module._load (module.js:280:25) at Module.require (module.js:364:17) ... 

我可以解决这个问题

 $> npm install socket.io 

现在当我再次执行安装命令时,

 Error: Cannot find module 'di' ... 

当我安装di并再次运行安装命令时,我得到:

 Error: Cannot find module 'log4js' 

我认为这可能会持续很长时间。 任何build议这里发生了什么,以及如何解决这个问题?

       

网上收集的解决方案 "npm install缺less模块"

运行npm install将安装package.json中指定的所有依赖项。 好像你有很多没有定义的依赖关系。 使用npm install packageName --save和npm将把包添加到你的package.json

我在引导一个MEAN应用程序时面临同样的问题,并添加每个缺less的依赖与npm install packageName --save -保存不是一个选项,所以我碰到了npm-install-missing谁救了我的命:)

安装

npm install -g npm-install-missing

用法

 npm-install-missing 

我正在使用相同版本的npm /节点。 有时候,就像npm是“迷路”一样。 我build议的是:

  • 你的节点模块(至less是有关的)
  • npmcaching清理
  • 运行“npm install”几次,直到解决所有依赖关系,并且不显示消息

看起来socket.io ,di ,log4js需要“业力”依赖( socket.io ,di ,log4js …),所以你将不得不运行:

npm install karma

所以只是运行这个命令解决了这个问题,一切都应该是好的,同样的事情也发生在grunt以及一些原因。