npm WARN弃用npmconf@2.1.2:这个包已经重新集成到npm中,现在已经过时了npm

我在CentOS 7服务器上安装node.js,当我尝试安装yeoman时,出现以下错误:

npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm 

yeoman的安装似乎正常工作。 有什么我可以做,以避免这种警告? 什么是没有处理的影响?

下面是从yeoman安装terminal输出的第一部分的其余部分:

 [root@localhost ~]# npm install -g yo npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm /usr/bin/yo -> /usr/lib/node_modules/yo/lib/cli.js > yo@1.6.0 postinstall /usr/lib/node_modules/yo > yodoctor Yeoman Doctor Running sanity checks on your system ✔ Global configuration file is valid ✔ NODE_PATH matches the npm root ✔ Node.js version ✔ No .bowerrc file in home directory ✔ No .yo-rc.json file in home directory ✔ npm version Everything looks all right! /usr/lib .... many lines of directory structure follow 

       

网上收集的解决方案 "npm WARN弃用npmconf@2.1.2:这个包已经重新集成到npm中,现在已经过时了npm"