npm用create-react-app启动错误

我有一个项目,我没有接触2个星期。 我拿回来,现在当我尝试运行npm start我得到这个错误。

 > react-scripts start sh: react-scripts: command not found npm ERR! Darwin 16.0.0 npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "start" npm ERR! node v6.7.0 npm ERR! npm v3.10.3 npm ERR! file sh npm ERR! code ELIFECYCLE npm ERR! errno ENOENT npm ERR! syscall spawn npm ERR! UpScore@0.6.0 start: `react-scripts start` npm ERR! spawn ENOENT npm ERR! npm ERR! Failed at the UpScore@0.6.0 start script 'react-scripts start'. npm ERR! Make sure you have the latest version of node.js and npm installed. npm ERR! If you do, this is most likely a problem with the UpScore package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! react-scripts start npm ERR! You can get information on how to open an issue for this project with: npm ERR! npm bugs UpScore npm ERR! Or if that isn't available, you can get their info via: npm ERR! npm owner ls UpScore npm ERR! There is likely additional logging output above. 
  • 节点6.7.0
  • npm 3.10.3
  • mac sierra 10.12

的package.json

 { "name": "UpScore", "version": "0.6.0", "private": true, "devDependencies": { "react-addons-test-utils": "^15.3.1", "react-scripts": "0.4.1", "react-test-renderer": "^15.3.1", "redux-logger": "^2.6.1" }, "dependencies": { "@yoshokatana/medium-button": "^1.1.0", "axios": "^0.14.0", "bcrypt": "^0.8.7", "bcrypt-nodejs": "0.0.3", "bcryptjs": "^2.3.0", "body-parser": "^1.15.2", "connect-flash": "^0.1.1", "cookie-parser": "^1.4.3", "draft-js": "^0.8.1", "draft-js-editor": "^1.7.2", "draft-js-export-html": "^0.4.0", "ejs": "^2.5.2", "email-verification": "^0.4.5", "express": "^4.14.0", "express-session": "^1.14.1", "flexboxgrid": "^6.3.1", "highlight.js": "^9.6.0", "immutable": "^3.8.1", "katex": "^0.6.0", "lodash": "^4.15.0", "markdown-it-mathjax": "^1.0.3", "material-ui": "^0.15.4", "medium-editor": "^5.22.0", "minutes-seconds-milliseconds": "^1.0.3", "moment": "^2.15.0", "moment-duration-format": "^1.3.0", "mongod": "^1.3.0", "mongodb": "^2.2.9", "mongoose": "^4.6.0", "monk": "^3.1.2", "morgan": "^1.7.0", "normalize.css": "^3.0.3", "passport": "^0.3.2", "passport-local": "^1.0.0", "react": "^15.3.1", "react-dom": "^15.3.1", "react-markdown": "^2.4.2", "react-medium-editor": "^1.8.1", "react-redux": "^4.4.5", "react-redux-form": "^0.14.5", "react-rich-markdown": "^1.0.1", "react-router": "^2.7.0", "react-router-redux": "^4.0.5", "react-tap-event-plugin": "^1.0.0", "react-tinymce": "^0.5.1", "redux": "^3.6.0", "redux-form": "^6.0.5", "redux-form-material-ui": "^4.0.1", "redux-promise-middleware": "^4.0.0", "redux-thunk": "^2.1.0", "reselect": "^2.5.3", "screenfull": "^3.0.2" }, "scripts": { "start": "react-scripts start", "start:prod": "pushstate-server build", "build": "react-scripts build", "test": "react-scripts test --env=jsdom", "eject": "react-scripts eject", "server": "cd client/api && pm2 start server.js --watch", "proxy": "http://128.199.139.144:3000" }, "eslintConfig": { "extends": "./node_modules/react-scripts/config/eslint.js" } } 

我试图克隆我的仓库,并得到相同的错误。 如果有人能给我一些方法来find发生的事情。 谢谢

       

网上收集的解决方案 "npm用create-react-app启动错误"

创buildReact App的作者签入。

你绝对不应该在全球安装react-scripts
这个答案意味着你也不需要./node_modules/react-scripts/bin/ package.json

如果你看到这个:

 npm ERR! UpScore@0.6.0 start: `react-scripts start` npm ERR! spawn ENOENT 

这只是意味着当第一次安装依赖关系时出了问题。

我build议做这三个步骤:

  1. npm install -g npm@latest更新npm,因为它有时是越野车。
  2. rm -rf node_modules删除现有的模块。
  3. npm install重新安装项目依赖关系。

这应该解决这个问题。
如果没有,请提供一个链接到您的项目和Node和npm版本的问题。

看起来你在全球环境中没有react-scripts 。 这里有两种可能性:

npm install -g react-scripts

或者在你的package.json中改变你的脚本部分是这样的:

  "scripts": { "start": "./node_modules/react-scripts/bin/react-scripts.js start", "start:prod": "pushstate-server build", "build": "./node_modules/react-scripts/bin/react-scripts.js build", "test": "./node_modules/react-scripts/bin/react-scripts.js test --env=jsdom", "eject": "./node_modules/react-scripts/bin/react-scripts.js eject", "server": "cd client/api && pm2 start server.js --watch", "proxy": "http://128.199.139.144:3000" }, 

是的,你不应该在全球安装react-scripts,这是行不通的。

我想我没有使用 – 保存当我第一次创build该项目(在另一台机器上),所以对我来说,这解决了这个问题:

 npm install --save react react-dom react-scripts