npm安装不拉入devDependencies

我有npm v 1.2.32

当我运行:$ npm install mongo-migrate

它不安装是一个devDependency的mongodb。

我究竟做错了什么?

       

网上收集的解决方案 "npm安装不拉入devDependencies"

从NPM存储库安装软件包时,不会自动安装开发依赖关系(因为不需要那些依赖关系来使主包正常工作)。

你需要明确地指示npm来安装开发依赖:

npm install mongo-migrate --dev 

更新

--dev命令已被弃用。

npm WARN安装--dev选项的用法已被弃用。 改用--only=dev

 npm install mongo-migrate --only=dev 

虽然与这个问题没有直接关系,但是有些人可能会感兴趣的是,如果将环境variablesNODE_ENV设置为production ,npm将在执行npm install时忽略devDependencies

npm i <package> # without devDependencies cd node_modules/<package> npm i # include devDependencies

“npm我–dev”是不正确的,因为它recursion地安装devDependencies。

我只是有这个相同的问题,只是这是因为我已经在我的package.json中定义了两次devDependencies。

我用手写拼写的方式写了它,在进行故障诊断时运行了一些–save-dev安装,使其显示两次。 顺便说一句,如果你在package.json中包含了两次“devDependencies”,npm将不会安装它们。

我偶尔也不得不安装devDependencies,即使NODE_ENV =生产。

我通常使用这种解决方法。

 // temporarily change NODE_ENV to other value... NODE_ENV=development npm install