NPM不工作(无法find模块'内部/ FS' – nodejs)

NPM错误更新。 我最近更新到节点版本7.x。 现在npm不工作。

我无法find错误,这可能是由于 –
npm ERR! Cannot find module 'internal/fs' npm ERR! Cannot find module 'internal/fs'

当我运行sudo npm update -g时,我得到以下内容 –

 npm ERR! Linux 3.13.0-101-generic npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "update" "-g" npm ERR! node v7.1.0 npm ERR! npm v3.10.8 npm ERR! code MODULE_NOT_FOUND npm ERR! Cannot find module 'internal/fs' npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues> 

我的/etc/profile.d/nodejs.sh有以下内容:

 NODE_PATH=/usr/lib/nodejs:/usr/lib/node_modules:/usr/share/javascript export NODE_PATH 

       

网上收集的解决方案 "NPM不工作(无法find模块'内部/ FS' – nodejs)"

您应该能够删除npm目录(通常为/ usr / local / lib / node_modules / npm),然后重新安装其中一个官方节点tarball,其中包括npm(您可以从http://nodejs.org/ dist / latest-v7.x / )。

你从旧版本的节点升级?

如果是这样,这可能是你有这个问题的原因之一。 较早版本的graceful-fs (依赖于npm)做了在v7中不再可用的东西。

根据这个线程 ,更新npm到版本4将解决您的问题,请尝试:

 npm i -g npm@4 

如果这不起作用,请尝试:

 ~/.n/n/versions/node/7.0.0/bin/npm i -g npm@4 

删除node_modules目录,然后input你的控制台“npm install”。 有一个原因,我不知道,如果你只更新npm,它不能解决这个错误,但重新安装npm一切都会好起来的。

对我来说,如果我遇到错误“找不到模块内部/ fs”,那就参考命令path。 更好地find命令path:

 npm config get prefix 

进入系统环境path。 面对这个错误几天后,我的工作。