无法通过npm安装gulp-jshint

当使用节点npm安装gulp-jshint时出现以下错误:“gulp-jshint@2.0.4需要jshint@2.x的对等端,但没有安装UNMET对等端的依赖关系”。 任何人都可以帮助解决这个问题。 我正在使用Windows 7操作系统。

       

网上收集的解决方案 "无法通过npm安装gulp-jshint"

尝试执行以下命令npm install --save-dev jshint gulp-jshint

如果这不起作用,请检查这个 github问题的回购。

npm install -g jshint

这个错误告诉你的是,你错过了gulp-jshint的依赖关系:在这种特殊情况下, jshint

jshint更喜欢全局安装,因此-g标志。

从gulp-jshint模块版本2.0开始,必须使用gulp-jshint安装jshint。 https://github.com/spalger/gulp-jshint

 npm install jshint gulp-jshint --save-dev