无法通过NPM安装Mongoose

我正在尝试通过npmmongoose下载到我的node.js项目中。

命令是npm install mongoose 。 但是,这导致下面的输出,并最终导致错误。 mongoose目录中唯一的东西是依赖关系(在node_modules文件夹中)。 任何其他包将工作,但mongoose多次失败。 我试过npm install -g mongoosesudo npm install mongoose ,但是它们都不能工作。

任何想法可能会出错?

节点版本0.10.20

npm版本1.3.11

 $ npm install mongoose npm WARN package.json mongo@0.1.0 No repository field. npm http GET https://registry.npmjs.org/mongoose npm http 304 https://registry.npmjs.org/mongoose npm http GET https://registry.npmjs.org/ms/0.1.0 npm http GET https://registry.npmjs.org/sliced/0.0.5 npm http GET https://registry.npmjs.org/hooks/0.2.1 npm http GET https://registry.npmjs.org/muri/0.3.1 npm http GET https://registry.npmjs.org/mongodb/1.3.19 npm http GET https://registry.npmjs.org/regexp-clone/0.0.1 npm http GET https://registry.npmjs.org/mpath/0.1.1 npm http GET https://registry.npmjs.org/mpromise/0.2.1 npm http 304 https://registry.npmjs.org/ms/0.1.0 npm http 304 https://registry.npmjs.org/sliced/0.0.5 npm http 304 https://registry.npmjs.org/hooks/0.2.1 npm http 304 https://registry.npmjs.org/muri/0.3.1 npm http 304 https://registry.npmjs.org/mongodb/1.3.19 npm http 304 https://registry.npmjs.org/regexp-clone/0.0.1 npm http 304 https://registry.npmjs.org/mpath/0.1.1 npm http 304 https://registry.npmjs.org/mpromise/0.2.1 npm ERR! Error: ENOENT, chmod '/Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mongodb/index.js' npm ERR! If you need help, you may report this log at: npm ERR! <http://github.com/isaacs/npm/issues> npm ERR! or email it to: npm ERR! <npm-@googlegroups.com> npm ERR! System Darwin 11.4.2 npm ERR! command "/Users/khanh/.nvm/v0.10.20/bin/node" "/Users/khanh/.nvm/v0.10.20/bin/npm" "install" "mongoose" npm ERR! cwd /Users/khanh/Code/bunnybots npm ERR! node -v v0.10.20 npm ERR! npm -v 1.3.11 npm ERR! path /Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mongodb/index.js npm ERR! fstream_path /Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mongodb/index.js npm ERR! fstream_type File npm ERR! fstream_class FileWriter npm ERR! fstream_finish_call chmod npm ERR! code ENOENT npm ERR! errno 34 npm ERR! fstream_stack /Users/khanh/.nvm/v0.10.20/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19 npm ERR! fstream_stack Object.oncomplete (fs.js:107:15) npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/hooks' npm ERR! error rolling back mongoose@3.6.20 { [Error: ENOTEMPTY, rmdir '/Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/hooks'] npm ERR! error rolling back errno: 53, npm ERR! error rolling back code: 'ENOTEMPTY', npm ERR! error rolling back path: '/Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/hooks' } npm ERR! Error: ENOENT, open '/Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mpath/package.json' npm ERR! If you need help, you may report this log at: npm ERR! <http://github.com/isaacs/npm/issues> npm ERR! or email it to: npm ERR! <npm-@googlegroups.com> npm ERR! System Darwin 11.4.2 npm ERR! command "/Users/khanh/.nvm/v0.10.20/bin/node" "/Users/khanh/.nvm/v0.10.20/bin/npm" "install" "mongoose" npm ERR! cwd /Users/khanh/Code/bunnybots npm ERR! node -v v0.10.20 npm ERR! npm -v 1.3.11 npm ERR! path /Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mpath/package.json npm ERR! code ENOENT npm ERR! errno 34 npm ERR! Error: ENOENT, open '/Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mpromise/README.md' npm ERR! If you need help, you may report this log at: npm ERR! <http://github.com/isaacs/npm/issues> npm ERR! or email it to: npm ERR! <npm-@googlegroups.com> npm ERR! System Darwin 11.4.2 npm ERR! command "/Users/khanh/.nvm/v0.10.20/bin/node" "/Users/khanh/.nvm/v0.10.20/bin/npm" "install" "mongoose" npm ERR! cwd /Users/khanh/Code/bunnybots npm ERR! node -v v0.10.20 npm ERR! npm -v 1.3.11 npm ERR! path /Users/khanh/Code/bunnybots/node_modules/mongoose/node_modules/mpromise/README.md npm ERR! code ENOENT npm ERR! errno 34 npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /Users/khanh/Code/bunnybots/npm-debug.log npm ERR! not ok code 0 

       

网上收集的解决方案 "无法通过NPM安装Mongoose"