升级npm和nodejs后如何修复npm包

在这种情况下,我如何修复量angular器

我已经安装了量angular器v1.6.1全局使用npm v低于2和节点低于1。

一路上我更新npmnode ,现在我使用npm v3.7.2node v4.2.6 。 作为量angular器说它的兼容性说我应该使用版本3,匹配node v 4

我愚蠢地做手动删除旧的量angular器v1.6.1当我安装新的量angular器是v3.1.1它说位于

 X:\nodejs `-- protractor@3.1.1 

但是当我必须validation它的工作,与protractor --version 。 它大叫:

 Error cannot find module `X:\AppData\Roaming\npm\node_modules\protractor\bin\protractor at ... 

如何解决这个问题? 谢谢

       

网上收集的解决方案 "升级npm和nodejs后如何修复npm包"

在量angular器移动或删除这些文件的情况下,如果您正确configurationnpmnodejs并成功安装新的protractor就解决问题。

 X:\AppData\Roaming\npm\protractor X:\AppData\Roaming\npm\protractor.md 

为了救我也搬

 X:\AppData\Roaming\npm\webdriver-manager X:\AppData\Roaming\npm\webdriver-manager.md 

您也可以select使用安装在nodejs installation dir npm。 有关详细信息,请参阅此处 (选项3)。

为了select这个选项,你可以使用当前使用的npm config prefix 。 要知道它运行以下命令:

 npm config get prefix -g 

我select选项3,因为目前我的机器使用

 X:\nodejs 

因为它是前缀。 对于Windows和故障排除相关,你可以在这里阅读,而对于npmconfiguration前缀本身,你可以在这里阅读