NPM过时和NPM更新不起作用

我想检查我的模块是否是最新的

我这样做: sudo npm outdated

我有这个结果

 Package Current Wanted Latest Location oauth 0.9.9 0.9.9 0.9.10 twit > oauth require-all 0.0.3 0.0.3 0.0.8 mysql > require-all bignumber.js 1.0.1 1.0.1 1.3.0 mysql > bignumber.js request 2.27.0 2.27.0 2.30.0 facebook-chat > node-xmpp > node-xmpp-client > request through 2.2.7 2.2.7 2.3.4 facebook-chat > node-xmpp > brfs > through 

那么我这样做: sudo npm update但如果我重复sudo npm outdated我有同样的结果…如果我做例如信息:

 Package Current Wanted Latest Location oauth 0.9.9 0.9.9 0.9.10 twit > oauth 

然后更新

 sudo npm update oauth 

然后

 sudo npm outdated oauth 

我的结果:

 Package Current Wanted Latest Location oauth 0.9.9 0.9.9 0.9.10 twit > oauth 

       

网上收集的解决方案 "NPM过时和NPM更新不起作用"

您的项目实际上是当前最新的。

NPM不会简单地安装Latest版本的软件包,除非该版本也是Wanted

产生的字段'wanted'根据package.json中指定的版本显示最新版本,[…]

而且,对于你列出的每一个, WantedCurrent版本已经匹配。

 Package Current Wanted ... oauth 0.9.9 0.9.9 ... require-all 0.0.3 0.0.3 ... bignumber.js 1.0.1 1.0.1 ... request 2.27.0 2.27.0 ... through 2.2.7 2.2.7 ... 

例如,尝试强制oauth到当前Latest0.9.10 ,实际上会被认为是invalid因为twit已经精确地列出了0.9.9

 "dependencies": { "oauth": "0.9.9" }, 
 $ npm ls ... └─┬ twit@1.1.11 └── oauth@0.9.10 invalid npm ERR! invalid: oauth@0.9.10 ...\node_modules\twit\node_modules\oauth 

检查你的package.json可能是你的软件包或那里。 尝试使用–save安装软件包,然后尝试使用它

例如:npm install underscore@1.5.0 – 保存现在尝试npm过期