如何解决在npm安装peerinvalid错误?

我试图按照步骤来贡献PhysicsJS( https://github.com/wellcaffeinated/PhysicsJS#contributing ),并在npm install出现以下错误。

 npm ERR! peerinvalid The package grunt-contrib-jasmine does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer grunt-template-jasmine-requirejs@0.1.10 wants grunt-contrib-jasmine@~0.5.3 npm ERR! System Linux 3.13.0-24-generic npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" npm ERR! cwd /home/slacktracer/Dropbox/dev/PhysicsJS npm ERR! node -v v0.10.26 npm ERR! npm -v 1.4.3 npm ERR! code EPEERINVALID npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /home/slacktracer/Dropbox/dev/PhysicsJS/npm-debug.log npm ERR! not ok code 0 

有关如何解决它的任何build议?

       

网上收集的解决方案 "如何解决在npm安装peerinvalid错误?"

它看起来像PhysicsJS的package.json需要更新,以便在"grunt-contrib-jasmine": "0.4.x",中的"grunt-contrib-jasmine": "0.4.x","grunt-contrib-jasmine": "0.5.x",

在我的情况(peerinvalid问题,但不同的模块),我不得不先卸载模块,然后再次安装它:

 npm uninstall MODULE npm install MODULE 

我还在package.json中为MODULE指定了一个固定版本,因为在我有一个版本范围之前:

 "MODULE": "1.42.2",