我如何解决这个消息“你真的不认为你可以通过npm安装Ruby,是吗?

我试图在我的Mac OSX Yosemite机器上安装自制软件。 当我尝试遵循传统的安装过程时:

$ ruby​​ -e“$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install )”

我一直在terminal上收到消息“你真的没有想到你可以通过npm安装Ruby,是吗?

据我所知,Yosemite在PATH中安装了Ruby 2.0。 如果是这样,为什么我不断收到这个消息,我该如何安装Ruby和Homebrew。

我在网上查了一些例子,但是安装Homebrew的每个例子都需要ruby,每个安装Ruby的例子都需要Homebrew。

SMH,为什么不给我一个我需要做的消息,而不是一个废话的喜剧消息呢?

       

网上收集的解决方案 "我如何解决这个消息“你真的不认为你可以通过npm安装Ruby,是吗?"

使用/usr/bin/ruby而不是普通的ruby已经build议将工作。

但是,这只是应用一个绷带; 你应该停止stream血,因为这个npmruby仍然会在你的路上,可能会回来咬你在后端。

更合理的方法是卸载 npmruby。 就像是:

 npm uninstall -g ruby 

尝试使用相同的命令,但是以/usr/bin/ruby开头,这是与OS X捆绑在一起的ruby的完全绝对path。如果你input的which ruby我猜你正在运行一个名为“ruby”的程序“如果你明白我的意思,不是你正在寻找的机器人”。 另一个很好的理智检查是/usr/bin/ruby -v应该打印类似于“ruby 2.0.0p481(2014-05-08 revision 45883)[universal.x86_64-darwin14]”。