npm从terminal安装错误

我想安装节点在我的MAC ..我收到以下错误…我从节点网站下载节点,并运行该包…你们可以告诉我为什么我面临着这个错误..当我做npm安装

MacBook-Pro:~ Raj$ npm install npm ERR! install Couldn't read dependencies npm ERR! package.json ENOENT, open '/Users/Raj/package.json' npm ERR! package.json This is most likely not a problem with npm itself. npm ERR! package.json npm can't find a package.json file in your current directory. npm ERR! System Darwin 13.0.0 npm ERR! command "node" "/usr/local/bin/npm" "install" npm ERR! cwd /Users/Raj npm ERR! node -v v0.10.26 npm ERR! npm -v 1.4.3 npm ERR! path /Users/Raj/package.json npm ERR! code ENOPACKAGEJSON npm ERR! errno 34 npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /Users/Raj/npm-debug.log npm ERR! not ok code 0 

       

网上收集的解决方案 "npm从terminal安装错误"

运行“npm install”会查找package.json中列出的依赖关系。 你得到的错误说你没有设置package.json文件(或者你在错误的目录中)。

如果您尝试安装特定的软件包,则应使用“npm install {软件包名称}”。 有关命令的更多信息,请参阅此处 。

否则,您需要为您的依赖项创build一个package.json文件,或者转到正确的目录,然后运行“npm install”。

试图在安装Node.js之前打开的terminal窗口中运行“npm install”时遇到了这个问题。

打开一个新的terminal窗口(即bash会话)工作。 (据推测,这为npm正确运行提供了正确的环境variables。)

您可能不在节点目录中。 尝试切换到您解压缩节点的目录并尝试在那里运行命令。

在我的情况下,这是由于一个错误的URL( http://而不是git:// ,没有.git在最后)。

在mac中,你可能已经下载并安装了Node js在/ Users / yourusername / Downloads / nodejs-todo-master,所以去这里运行npm install命令,不需要sudo,你应该得到这样的输出…

 underscore@1.4.4 node_modules/underscore ejs@0.8.8 node_modules/ejs redis@0.8.6 node_modules/redis jasmine-node@1.0.28 node_modules/jasmine-node ├── walkdir@0.0.7 ├── coffee-script@1.8.0 (mkdirp@0.3.5) ├── requirejs@2.1.15 └── jasmine-reporters@1.0.1 (mkdirp@0.3.5) express@3.0.6 node_modules/express ├── methods@0.0.1 ├── fresh@0.1.0 ├── range-parser@0.0.4 ├── cookie-signature@0.0.1 ├── buffer-crc32@0.1.1 ├── cookie@0.0.5 ├── commander@0.6.1 ├── mkdirp@0.3.3 ├── debug@2.1.0 (ms@0.6.2) ├── send@0.1.0 (mime@1.2.6) └── connect@2.7.2 (pause@0.0.1, bytes@0.1.0, formidable@1.0.11, qs@0.5.1) 

如果它帮助别人 – 我的问题是一个菜鸟错误,我在我的package.json的名字行中有一个空间,并导致依赖不可读。

首先从https://github.com/npm/read-package-json下载json包文件,然后从terminal运行npm install

这完全是因为你不在所需的目录中。 您需要先进入所需的目录。 我是angular手机目录。 所以我inputcd angular-phonecat然后npm install

我遇到过这个,我的问题是使用旧版本的节点(3.X),当需要更新的版本。

错误信息实际上也提示了这一点:

 ... Make sure you have the latest version of node.js and npm installed ... 

所以解决scheme可能像升级node / npm一样简单。 您可以使用nvm轻松完成此操作 ,“节点版本pipe理器”

安装nvm ,只需运行以下命令即可安装并使用最新版本的节点:

nvm install node

例如:

 $ nvm install node Downloading https://nodejs.org/dist/v8.2.1/node-v8.2.1-darwin-x64.tar.xz... ######################################################################## 100.0% Now using node v8.2.1 (npm v5.3.0) $ node --version v8.2.1