npm为什么要坚持“UNMET PEER DEPENDENCY”?

我search了很多关于“npm UNMET PEER DEPENDENCY”的post。 但是这个仍然令人困惑:

Hulk node_modules # npm install -g rxjs@5.0.0-beta.6 - symbol-observable@0.2.4 node_modules/rxjs/node_modules/symbol-observable /usr/lib └── rxjs@5.0.0-beta.6 Hulk node_modules # npm install -g zone.js@^0.6.6 /usr/lib └── zone.js@0.6.12 Hulk node_modules # Hulk node_modules # Hulk node_modules # Hulk node_modules # Hulk node_modules # npm install -g @angular/core /usr/lib ├── @angular/core@2.0.0-rc.1 ├── UNMET PEER DEPENDENCY rxjs@5.0.0-beta.6 └── UNMET PEER DEPENDENCY zone.js@^0.6.6 npm WARN @angular/core@2.0.0-rc.1 requires a peer of rxjs@5.0.0-beta.6 but none was installed. npm WARN @angular/core@2.0.0-rc.1 requires a peer of zone.js@^0.6.6 but none was installed. 

首先,当我尝试安装“@ angular / core”时,npm抱怨依赖关系

我安装了这些依赖关系,它仍然抱怨。

为什么? 感谢您的见解。

       

网上收集的解决方案 "npm为什么要坚持“UNMET PEER DEPENDENCY”?"