如何解决peer dependency错误:包react@15.3.2不满足其兄弟的peerDependencies要求

我运行npm install时出现这个错误。 这似乎是因为我无法满足一些同伴依赖,但我不确定哪个同伴依赖我需要修复。

λ npm install npm ERR! Windows_NT 10.0.14393 npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" npm ERR! node v4.6.0 npm ERR! npm v2.15.9 npm ERR! code EPEERINVALID npm ERR! peerinvalid The package react@15.3.2 does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer belle@2.0.7 wants react@>=0.14.0 || ^15.0.0-rc npm ERR! peerinvalid Peer material-ui@0.15.4 wants react@^15.0.0 npm ERR! peerinvalid Peer react-infinite@0.9.2 wants react@^15.0.0 npm ERR! peerinvalid Peer react-input-field@1.2.4 wants react@>=0.12.0 npm ERR! peerinvalid Peer react-router@0.13.6 wants react@0.13.x || 0.14.x || ^15.0.1 npm ERR! peerinvalid Peer react-tap-event-plugin@0.2.2 wants react@^0.14.0 npm ERR! peerinvalid Peer react-toolbox@1.2.1 wants react@~0.14 || ~15.3.0 npm ERR! peerinvalid Peer react-addons-css-transition-group@15.3.2 wants react@^15.3.2 npm ERR! peerinvalid Peer react-dom@15.3.2 wants react@^15.3.2 npm ERR! Please include the following file with any support request: npm ERR! C:\Users\Daljeet\Documents\hive\client\npm-debug.log 

我还附上了一个package.json的副本

 dependencies: "dependencies": { "belle": "^2.0.7", "body-parser": "^1.6.5", "bootstrap": "^3.3.0", "compression": "^1.0.11", "config": "^1.21.0", "config-js": "^1.1.9", "connect-ensure-login": "^0.1.1", "cors": "^2.4.1", "dateformat": "^1.0.12", "dotenv": "^0.4.0", "errorhandler": "^1.1.1", "express": "^4.8.5", "express-jwt": "^0.3.1", "flux": "^2.0.1", "i": "^0.3.5", "immutability-helper": "^2.0.0", "jsonwebtoken": "^5.0.1", "jwt-decode": "^1.1.0", "keymirror": "^0.1.1", "lodash": "4.0.0", "log4js": "^0.6.38", "material-ui": "~0.15.4", "mongoose": "^4.3.4", "morgan": "^1.2.3", "normalize.css": "^4.2.0", "pg": "^4.5.5", "react": "15.3.2", "react-infinite": "^0.9.2", "react-input-field": "^1.2.4", "react-mixin": "^1.1.0", "react-router": "^0.13.2", "react-star-rating": "^1.4.2", "react-tap-event-plugin": "~0.2.2", "react-toolbox": "^1.2.1", "react-virtual-list": "^1.8.0", "reqwest": "2.0.5", "when": "^3.7.2" }, "devDependencies": { "babelify": "^6.1.0", "browser-sync": "^2.1.6", "browserify": "^8.0.3", "clean-css": "^3.1.9", "eslint": "^0.14.1", "nodemon": "^1.5.0", "rework": "^1.0.1", "rework-npm": "^1.0.0", "rework-npm-cli": "^0.1.1", "serve": "^1.4.0", "uglify-js": "^2.4.15", "watchify": "^2.1.1" } } 

       

网上收集的解决方案 "如何解决peer dependency错误:包react@15.3.2不满足其兄弟的peerDependencies要求"