在远程托pipe的node-webkit应用程序中使用require()

我有一个package.json文件,如下所示:

{ "name": "title", "description": "description", "version": "0.1", "main": "https://path-to-application/", "window": { "show": true, "toolbar": false, "frame": true, "position": "center", "width": 800, "height": 600, "min_width": 220, "min_height": 220 } } 

但是当我尝试运行代码时:

 var GUI = null; var win = null; try { GUI = require('nw.gui'); win = GUI.Window.get(); } catch (ex) { } win.toggleFullscreen(); 

没有任何反应,为graphics用户界面添加警报,赢得节目都设置为空。 当我从package.json的.zip中运行相同的代码的index.html文件,它按预期工作。 初次调用require()似乎失败了。

有没有办法让这个工作在远程托pipe的应用程序?

       

网上收集的解决方案 "在远程托pipe的node-webkit应用程序中使用require()"