React Native + Firebase + Expo版本喜欢三angular形问题

我正在尝试使用Expo实现与Firebase的React Native身份validation。 我目前有以下版本:

我得到以下错误:

错误:未安装React native。 请在您的项目目录下运行npm install

我怎么到这儿来的

世博会推荐npm版本4.6.1。 (事实上​​,在这个博客论坛里 ,有关npm破解应用的post,build议降级到npm的版本。 但是firebase 4.3.0无法使用npm版本4.6.1进行安装。 所以我升级了npm到最新的5.4.0。 Firebase安装好了,但是现在我在世博会上得到了上面的错误。 当我尝试使用npm 4.6.1安装firebase时,这里是错误信息:

在这里输入图像描述

问题(S)

  • 我可以使用一些旧版本的firebase,它将与npm 4.6.1一起使用吗? 那是哪个版本?
  • 有没有其他的解决方法(其他较旧的Firebase版本)? 有没有人成功实施RN + Firebase + Expo?

编辑 :在世博论坛上寻求答案: 链接

       

网上收集的解决方案 "React Native + Firebase + Expo版本喜欢三angular形问题"