React Native构build警告问题?

在运行react-native init reactApp我得到一个警告npm WARN react-native@0.39.2 requires a peer of react@~15.4.0-rc.4 but none was installed 。 构build是成功的,虽然这是我的package.json构build之后。

 { "name": "reactApp", "version": "0.0.1", "private": true, "scripts": { "start": "node node_modules/react-native/local-cli/cli.js start", "test": "jest" }, "dependencies": { "react": "15.4.1", "react-native": "0.39.2" }, "devDependencies": { "babel-jest": "18.0.0", "babel-preset-react-native": "1.9.1", "jest": "18.0.0", "react-test-renderer": "15.4.1" }, "jest": { "preset": "react-native" } } 

这是一个问题吗? 我应该改变反应版本,然后运行npm install ? 我是完全陌生的反应/反应原生,所以任何意见,将不胜感激,以防止在未来的错误的最佳做法。

谢谢!

       

网上收集的解决方案 "React Native构build警告问题?"

我一直在使用React Native 3周。 在运行react-native init Proj我有类似的警告:

npm WARN react-native@0.39.2需要react@~15.4.0-rc.4的同行,但没有安装。

并且

npm WARN弃用minimatch@2.0.10:请更新至minimatch 3.0.2或更高版本以避免RegExp DoS问题

npm WARN比较喜欢全局的标记:@ 0.3.6应该用-g来安装

但是,这并没有影响我的工作。 编写代码并运行时,我没有遇到任何问题。

你可以随时运行:

npm install --save react@15.4 ,它应该修复它,但你的版本是目前最新的,所以我不会这样做。

React Native将使用早期版本的React,但不能保证。 如果你愿意,你可以更新你的React版本来修复对等的依赖。

我也有这个问题。 更新反应/反应本地版本到最新修复我的问题。

的package.json

 "react": "^16.0.0-beta.5", "react-native": "0.47.0", "react-test-renderer": "^16.0.0-beta.5"