在React代码中导入superagent时出错

我有一个用JSX编写的NodeJS服务器代码,我在这里导入superagent

import request from 'superagent'; 

当服务器启动后生成,我得到以下错误:TypeError:require不是一个函数。 这发生在我编译的代码中的以下行:

 var crypto = require('crypto'); 

在回溯中,我意识到encryption是“强大”所要求的,这是“超级”所要求的。

我在客户端JavaScript代码中具有相同的superagent导入,但工作正常。 我将节点(服务器)和客户端的编译JS代码进行了比较,两者都是相同的。 所以它的构build方式似乎不是一个问题。

有没有人看过这个错误,你会知道需要做什么?

       

网上收集的解决方案 "在React代码中导入superagent时出错"