如何切换root用户的Nodejs版本?

我遇到了这里发布的问题,并通知可能是nodejs的版本。

如下所示,节点版本很好。

$node -v v7.2.0 

但它给了我一个root用户的exception版本,这是由crontab进程使用的。

 $sudo su $node -v v0.10.42 

我试过$n rm 0.10.42$n 7.2.0多次都不能解决这个问题

有人可以帮忙吗? 我想要crontab进程使用正确版本的nodejs。

       

网上收集的解决方案 "如何切换root用户的Nodejs版本?"

我通过删除原始节点来解决问题,而不是复制新版本。

 $sudo su $node -v v0.10.42 //old version $which node /usr/bin/node $mv /usr/bin/node /usr/bin/node.bk //rename the old node $node -v bash: /usr/bin/node: No such file or directory $n bin 7.2.0 //find out the path of the new node installed /usr/local/n/versions/node/7.2.0/bin/node $cp /usr/local/n/versions/node/7.2.0/bin/node /usr/bin/node //replace $node -v v7.2.0 //success 

也许你可以尝试使用nvm来pipe理你的节点版本。 请使用命令安装nvm curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.32.1/install.sh | bash curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.32.1/install.sh | bash

尝试执行nvm install version来安装你想要的版本,并使用nvm use version来select你想要的。

我发现我可以简单地将正确的which nodepath添加到$ PATH。

 $which node /usr/local/bin/node $sudo su $which node /usr/bin/node $export PATH=$PATH:/usr/local/bin $node -v v7.2.0