可以select添加到npm package.json依赖关系?

我有一个与sqlite3包依赖。

默认情况下,安装时,sqlite3包会下载并使用sqlite3引擎的预打包版本。 这在使用sqlite3扩展时有时可能会成为问题,因此可以使用以下选项进行安装:

npm install --build-from-source --sqlite=/path/to/sqlite sqlite3 

“–build-from-source”和“–sqlite”都是由sqlite3包处理的选项。

现在我怎么能告诉package.json安装我的依赖与这些选项?

 "dependencies": { "sqlite3": "*" } 

显然我得到相当于

 npm install sqlite3 

但我找不到强制sqlite3包的–build-from-source和–sqlite选项的方法

       

网上收集的解决方案 "可以select添加到npm package.json依赖关系?"