使用yeoman生成angular度应用时出错:未处理的模板渲染错误

我想用yeoman生成一个angular度的应用程序结构,但一个错误阻止了我。

yo-->Angular Bootstrap-->more options-->

发生错误:

 Possibly unhandled Template render error: (unknown path) [Line 3, Column 90] expected variable end at Object.exports.withPrettyErrors (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/nunjucks/src/lib.js:33:17) at Obj.extend.render (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/nunjucks/src/environment.js:344:20) at Obj.extend.renderString (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/nunjucks/src/environment.js:231:21) at Generator.engine [as _engine] (/usr/lib/node_modules/generator-angular-bootstrap/app/modules/nunjucks-engine.js:17:14) at Generator.engine (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/yeoman-generator/lib/actions/actions.js:314:10) at Generator.template (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/yeoman-generator/lib/actions/actions.js:289:15) at setupAppFiles (/usr/lib/node_modules/generator-angular-bootstrap/app/index.js:209:10) at tryCatch1 (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/bluebird/js/main/util.js:45:21) at Promise$_callHandler [as _callHandler] (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/bluebird/js/main/promise.js:658:13) at Promise$_settlePromiseFromHandler [as _settlePromiseFromHandler] (/usr/lib/node_modules/generator-angular-bootstrap/node_modules/bluebird/js/main/promise.js:672:18) 

那么,任何人都可以帮助我?

       

网上收集的解决方案 "使用yeoman生成angular度应用时出错:未处理的模板渲染错误"

我已经通过将版本从0.5.1降级到0.4.3“解决”了:

 $ sudo npm uninstall -g generator-angular-bootstrap $ sudo npm install -g generator-angular-bootstrap@0.4.3 $ yo angular-bootstrap 

这个错误似乎与在0.5.0版中引入的nunjucks有关(我在0.5.0和0.5.1中遇到过错误); 并可能与我无法快速识别的其他东西有关。

删除/ usr / lib / node_modules并在本教程中再次安装所有依赖项:http: //yeoman.io/codelab/setup.html

之后,你可以运行“哟angular”,并selectBootstrap作为依赖之一。

我不知道你得到了答案,但你可以去默认的项目一代,它自己引导。