Yeoman,Angular Generator和Karma Test不起作用

我正在试图使用angular发生器的 Yeoman来启动一个新的应用程序。

我运行这个命令(根据文档)开始一个新的应用程序:

yo angular my-app-name

所有的依赖已经下载,如果我运行

grunt serve

我的基本应用程序显示在浏览器中,一切看起来工作正常。 当我尝试运行时,问题就开始了:

grunt test

我得到一个错误: Warning: Task "karma" not found. Use --force to continue. Warning: Task "karma" not found. Use --force to continue.

所以我添加了这些行:

 "grunt-karma": "*", "generator-karma": "*" 

在我的packeage.json文件中,删除node_modules文件夹并`npm install 。 我正在解决这个问题,但现在我得到的错误:

 loading "grunt-karma.js" tasks...ERROR >> Error: Cannot find module 'socket.io-client' Warning: Task "karma" not found. Use --force to continue. Aborted due to warnings. 

我试图谷歌一点,但我找不到任何关于。 我正在运行MacOsX 10.8.5和节点v0.10.0。 任何build议?

提前致谢

       

网上收集的解决方案 "Yeoman,Angular Generator和Karma Test不起作用"

Karma和angular度发生器存在问题。 你正在运行最新版本的发电机?

不知道是什么导致了失败,但有时还有安装业力依赖关系的问题。 尝试运行:

 npm install grunt-karma karma-ng-html2js-preprocessor karma-ng-scenario --save-dev 

如果这样做不起作用,那么现在可以使用的解决方法是在安装失败后将以下依赖项添加到您的package.json中:

 "karma-ng-scenario": "~0.1.0", "grunt-karma": "~0.6.2", "karma-script-launcher": "~0.1.0", "karma-chrome-launcher": "~0.1.2", "karma-firefox-launcher": "~0.1.2", "karma-html2js-preprocessor": "~0.1.0", "karma-jasmine": "~0.1.5", "requirejs": "~2.1.9", "karma-requirejs": "~0.2.1", "karma-coffee-preprocessor": "~0.1.1", "karma-phantomjs-launcher": "~0.1.1", "karma": "~0.10.8", "karma-ng-html2js-preprocessor": "~0.1.0" 

然后再次运行npm install。

yeoman发行版(2014年12月)错过了库js文件,因为testing中的karma.conf.is指向bower_components,这可能是错误的。 更改karma.conf.is文件并将bower_componentsreplace为node_modules。

问题的原因发生在早期阶段。 解决方法是不改变kamaconfiguration文件,但执行命令:git config –global url。“https://”.insteadOf git://