安装Zombie.js错误:ReferenceError:Set未定义。 我究竟做错了什么?

背景:目前我正在阅读Ethan Brown的“ 用Node和Express进行Web开发 ”(这是一本很棒的书,对于那些学习节点和快车),而我却陷入了第5章 – 质量保险。

一切顺利。 首先我跑了以下几点:

npm install –save-dev摩卡

npm安装-g摩卡

npm install –save-dev chai

npm install –save-dev僵尸

问题:然后我跑(按照书的指示):

mocha -u tdd -R spec qa / tests-crosspage.js 2> / dev / null

但是这没有做任何事情。 所以然后我跑了:

mocha -u tdd -R spec qa / tests-crosspage.js

然后出现这个错误:

/Users/esanz91/Desktop/CodingNotes/Node/MySite/node_modules/zombie/node_modules/jsdom/lib/jsdom/level2/html.js:405 var nonInheritedTags = new Set([

ReferenceError:Set没有定义

版本:只是给你们一个想法,我已经安装了以下版本。

CMD:

npm list –depth = 0

结果:

├──chai@2.2.0

├──express@4.12.3

├──express3-handlebars@0.5.2

├──mocha@2.2.4

└──zombie@4.0.7

另外,我在节点0.10上运行。

我该如何解决这个问题?

谢谢!

       

网上收集的解决方案 "安装Zombie.js错误:ReferenceError:Set未定义。 我究竟做错了什么?"

我find了自己的问题的答案。 我实际上需要将Zombie 4.0.7降级到3.1.x,以便mochatesting命令可以使用节点0.10。

编辑1:我决定升级我的节点版本为0.12和我的僵尸版本备份到4.0.7,也工作。 (看起来像节点0.10和僵尸4.0.7不兼容…)

编辑2:对于读这本书的人来说,我build议看作者本人的github 回购 。 看一下package.json文件,看看他使用哪个版本的模块。